grub2(或brug)引导下重装Win7出现的问题及解决

  • 2012-01-04
  • 0
  • 2

系统安装情况   64位win7 +xp+ubuntu11.10

主硬盘分区情况如下:

/dev/sda1 安装的win7

/dev/sda2 安装的XP

ubuntu安装在 /dev/sda8

系统引导一直由grub2引导,后来又安装了burg

由于64位win7实在不方便折腾系统美化,于是昨晚做了个十分艰难的决定:重新装回32位win7

U盘、光盘(备用)准备完毕

开机重U盘启动,加载已写入的win7安装程序  一切都看起来是那么顺利….等啊等  终于等到“系统安装将在重启后继续”

尼玛,光明就在前方,果断重启。。。BIOS检测完毕  继续‘顺利’进行着    “正在配置系统设置”、”正在更新…“、”….“….  

接下来的事情就只能这么说了:你吃着瓜子,装着这系统,突然就弹出个错误框 “Windows无法更新计算机启动配置..”。。。。我简直比葛优还郁闷啊

冷静下,重启看看。还未等几秒钟  下头就提示 “Brug is loading…”     好吧  这明显是没有重写MBR啊    Burg都还在加载     我是在想不出我哪出错了,理论上来说,安装版的系统安装过程中应该会重写MBR的  难道是Burg的原因导致的?既然想到就试试吧    进Ubuntu的终端执行

sudo apt-get remove burg burg-themes burg-emu

不多时  提示卸载成功了

接着更新下grub(免得到时候又不成功 我连XP都进不去了)

sudo update-grub

再次就绪  再次重启安装

等啊等啊 ····反正是漫长的等待,重启,继续悲催中…

这就郁闷了    MBR被写保护了?没道理啊  

进入PE用winPM重建MBR  重启   “grub is loading…”

我还能说点什么呢····简直是要奔溃     

试试Ghost吧 (真的不抱一点希望,传说ghost还原是不会去动MBR的)

无论是用Ghost的硬盘版还是一键还原版   不是提示先前的那个错误就是安装到一半直接蓝屏了····苍天哪!!救救我吧

纠结了半天,还是决定去DOS下用

fdisk /mbr

试试   

本来就不抱希望(毕竟WinPM也试过了)   God果然也不给我一点希望  依旧   grub is loading…        

spfdisk /mbr 实在不想去试了

慢慢的

my despair is loading““““

绝望中  想过  全盘格式化    这终极必杀技想必能行  但一定得酝酿几天才有那么大的勇气啊!!!!

要不试试把win7分区删了再新建试试吧 这也是最后的得救之道了

继续进PE  删除 新建 格式化    

终于  

终于  

那可亲可爱的Win7引导界面终于出来了   尽管是提示在不到启动文件  但那只是多二三十分钟重新安装的问题   你想啊   亲    我都已经这样不停的安装持续了三四个小时了   还在乎这点时间吗!!!

好吧  激动了  本来两句话可以写清的问题写了这么多    但实在是在绝望中突然抓到了那么希望居然顺利解决问题   咱能不激动吗    

至于MBR出的那问题再慢慢研究吧

==============时间分割线=============

2012.1.7

win7装成功了   可是习惯了以前的Burg引导界面  于是乎去修复ubuntu

Livcd下成功挂载分区到 \mnt 然后安装了grub  重启

偶滴个神哪!  grub引导界面居然没出来  还是win7的引导界面  难道我的MBR真的出问题了

一次次尝试  终于发现问题了   由于我的是双硬盘    那个没有安装系统的硬盘在逻辑上排在了我系统硬盘的前面

也就是说系统默认把我那块非系统硬盘当作了引导盘  导致我每次尝试安装系统(包括今天修复Grub)时重写的MBR是位于那块非系统盘上

然后我重启时 加载的确实主硬盘上的引导  自然就造成了MBR无论如何都不改变的假象

(以上纯属猜测  高手飘过请指教)

既然是这样  重启进入BIOS 先暂时把那块非系统盘禁用  这时便看到了久违的Grub引导了   进入Ubuntu     update-grub  更新下引导

 

然后安装Burg

…….

上一篇:    下一篇:

me@ccc5.cc - 衫小寨